package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)eed1([a-z0-9]{4})`)
var str = `F000668A-EED14F50-000EED1kFF0000000F03`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}