$re = '/eed1([a-z0-9]{4})/i';
$str = 'F000668A-EED14F50-000EED1kFF0000000F03';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);