using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^await(?:(?!\.lean\(\)).)*;$";
string input = @"await Listing.find({
Test: 1;
});
await Listing.find({
Test: 1
}).lean();
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}