re = /^await(?:(?!\.lean\(\)).)*;$/m
str = 'await Listing.find({
Test: 1;
});
await Listing.find({
Test: 1
}).lean();
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end