#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?Xm)^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[#?!@$%^&*-])((.)(?!\2\2))+$"
Local $sString = "" & @CRLF & _
"Password123$" & @CRLF & _
"" & @CRLF & _
"PPaassword123$$" & @CRLF & _
"" & @CRLF & _
"Passsword123$" & @CRLF & _
"" & @CRLF & _
"Passssword123$" & @CRLF & _
"" & @CRLF & _
"PPaassword123$$$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")