re = /^(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9])(?=.*[#?!@$%^&*-])((.)(?!\2\2))+$/m
str = '
Password123$
PPaassword123$$
Passsword123$
Passssword123$
PPaassword123$$$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end