package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^s3n?:\/\/(.*)`)
var str = `s3://hello/world
s3n://hello/again`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}