$re = '/^s3n?:\/\/(.*)/m';
$str = 's3://hello/world
s3n://hello/again';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);