$re = '/^(?![ -.&,_\'":?!/])(?!.*[- &_\'":]$)(?!.*[-.#@&,:?!/]{2})[a-zA-Z0-9- .#@&,_\'":.?!/]+$/';
$str = 'The Address Downtown';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);