re = /^(?![ -.&,_'":?!\/])(?!.*[- &_'":]$)(?!.*[-.#@&,:?!\/]{2})[a-zA-Z0-9- .#@&,_'":.?!\/]+$/
str = 'The Address Downtown'
# Print the match result
str.match(re) do |match|
puts match.to_s
end