using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^GROUPS:\h*\[""(?=[^][]*])|\G(?!^),\h*"")(?<name>[^:]+):(?<id>\d+)""";
string input = @"GROUPS: [""group1:44343"", ""group2:23324"", ""group3:66567""]
USERS: [""user1:44343"", ""user2:23324"", ""user3:66567""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}