import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^GROUPS:\\h*\\[\"(?=[^][]*])|\\G(?!^),\\h*\")(?<name>[^:]+):(?<id>\\d+)\"";
final String string = "GROUPS: [\"group1:44343\", \"group2:23324\", \"group3:66567\"]\n\n"
+ "USERS: [\"user1:44343\", \"user2:23324\", \"user3:66567\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}