const regex = /\A(?:[^\|]+\|){2}\K(?P<foo>[^\|]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A(?:[^\\|]+\\|){2}\\K(?P<foo>[^\\|]*)', 'g')
const str = `2017-05-13|23:59:59|127.0.0.1|8080|ReGeX|http://www.example.com/index.htm|!"£\$%^&*()_+|qwerty`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}