package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)I am (?:\d+) years old`)
var str = `ex1: I am * years old
valid matches:
- "I am 24 years old"
invalid match:
- "I am years old"
ex2: what color is [my|your|his|her|its|our|their] (red|blue|green|yellow) *
valid matches:
- "what color is his dog"
- "what color is my some random text till the end of string"
ex3: [*] told me to say *
valid matches:
- "Bob and Alice told me to say hallelujah"
- "told me to say by nobody"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}