re = /I am (?:\d+) years old/m
str = 'ex1: I am * years old
valid matches:
- "I am 24 years old"
invalid match:
- "I am years old"
ex2: what color is [my|your|his|her|its|our|their] (red|blue|green|yellow) *
valid matches:
- "what color is his dog"
- "what color is my some random text till the end of string"
ex3: [*] told me to say *
valid matches:
- "Bob and Alice told me to say hallelujah"
- "told me to say by nobody"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end