package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.{2})|(\\{1})|(\${1})`)
var str = `\\TestServer\User_Attachments$\Data\Reference\Input\Test.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}