re = /^(.{2})|(\\{1})|(\${1})/
str = '\\\\TestServer\\User_Attachments$\\Data\\Reference\\Input\\Test.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end