#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*\.)(\d+)\\(\n\1\d+\\)+$"
Local $sString = "D:\folder1\folder2\folder3\Artifact\Artifact-1.1\" & @CRLF & _
"D:\folder1\folder2\folder3\Artifact\Artifact-1.2\" & @CRLF & _
"D:\folder1\folder2\folder3\Artifact\Artifact-1.3\" & @CRLF & _
"D:\folder1\folder2\folder3\Different_Artifact\Different_Artifact-17.1\" & @CRLF & _
"D:\folder1\folder2\folder3\Different_Artifact\Different_Artifact-17.4\" & @CRLF & _
"D:\folder1\folder2\folder3\Different_Content\Different_Content-2.0\" & @CRLF & _
"D:\folder1\folder2\folder3\folder4\Different_Content\Different_Content-2.0\" & @CRLF & _
"D:\folder1\folder2\folder3\folder4\Different_Content\Different_Content-2.2\"
Local $sSubst = "$1$2\\"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)