using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*\.)(\d+)\\(\n\1\d+\\)+$";
string substitution = @"$1$2\\";
string input = @"D:\folder1\folder2\folder3\Artifact\Artifact-1.1\
D:\folder1\folder2\folder3\Artifact\Artifact-1.2\
D:\folder1\folder2\folder3\Artifact\Artifact-1.3\
D:\folder1\folder2\folder3\Different_Artifact\Different_Artifact-17.1\
D:\folder1\folder2\folder3\Different_Artifact\Different_Artifact-17.4\
D:\folder1\folder2\folder3\Different_Content\Different_Content-2.0\
D:\folder1\folder2\folder3\folder4\Different_Content\Different_Content-2.0\
D:\folder1\folder2\folder3\folder4\Different_Content\Different_Content-2.2\";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}