using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^From:\s[A-Za-z]+\s[A-Za-z]+(\s[A-Za-z]+)?(\s[A-Za-z]+)?\s<[A-Za-z]+@domain\.com>";
string input = @"From: FirstName MiddleName Surname <FirstNameMiddleNameSurname@domain.com>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}