$re = '/^From:\s[A-Za-z]+\s[A-Za-z]+(\s[A-Za-z]+)?(\s[A-Za-z]+)?\s<[A-Za-z]+@domain\.com>/m';
$str = 'From: FirstName MiddleName Surname <FirstNameMiddleNameSurname@domain.com>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);