package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(SCREEN){0}.*$`)
var str = `SCREEN containing test line
Another test line`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}