#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)P1127_VELOCITIES #001000 Step: (\d+) Iteration: (\d+) Time: (\d+\.\d+) {1,2}(\d*\.\d+|-\d*\.\d+)"
Local $sString = "Number of zero columns: 4" & @CRLF & _
"Memory requirement - global matrix: 1571340 solver (totally): 1571340" & @CRLF & _
"P1127_VELOCITIES #001000 Step: 59 Iteration: 2 Time: 0.04055 0.0015347 " & @CRLF & _
"P2243_VELOCITIES #001000 Step: 59 Iteration: 2 Time: 0.04055 0.0017193 " & @CRLF & _
"P3387_VELOCITIES #001000 Step: 59 Iteration: 2 Time: 0.04055 0.0015347 " & @CRLF & _
"% of load in interval Step: 59 Iteration: 2 Time: 0.04055 0.0400000 0.0400000 " & @CRLF & _
"summation % of load in interval Step: 59 Iteration: 2 Time: 0.04055 0.0800000 " & @CRLF & _
"" & @CRLF & _
"Number of zero columns: 4" & @CRLF & _
"Memory requirement - global matrix: 1571340 solver (totally): 1571340" & @CRLF & _
"P1127_VELOCITIES #001000 Step: 59 Iteration: 2 Time: 0.01638 -0.0016876 " & @CRLF & _
"P2243_VELOCITIES #001000 Step: 59 Iteration: 2 Time: 0.01638 -0.0018896 " & @CRLF & _
"P3387_VELOCITIES #001000 Step: 59 Iteration: 2 Time: 0.01638 -0.0016876 " & @CRLF & _
"% of load in interval Step: 59 Iteration: 2 Time: 0.01638 0.0400000 0.0400000 " & @CRLF & _
"summation % of load in interval Step: 59 Iteration: 2 Time: 0.01638 0.0800000 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")