import re
regex = re.compile(r"P1127_VELOCITIES #001000 Step: (\d+) Iteration: (\d+) Time: (\d+\.\d+) {1,2}(\d*\.\d+|-\d*\.\d+)", flags=re.MULTILINE)
test_str = ("Number of zero columns: 4\n"
"Memory requirement - global matrix: 1571340 solver (totally): 1571340\n"
"P1127_VELOCITIES #001000 Step: 59 Iteration: 2 Time: 0.04055 0.0015347 \n"
"P2243_VELOCITIES #001000 Step: 59 Iteration: 2 Time: 0.04055 0.0017193 \n"
"P3387_VELOCITIES #001000 Step: 59 Iteration: 2 Time: 0.04055 0.0015347 \n"
"% of load in interval Step: 59 Iteration: 2 Time: 0.04055 0.0400000 0.0400000 \n"
"summation % of load in interval Step: 59 Iteration: 2 Time: 0.04055 0.0800000 \n\n"
"Number of zero columns: 4\n"
"Memory requirement - global matrix: 1571340 solver (totally): 1571340\n"
"P1127_VELOCITIES #001000 Step: 59 Iteration: 2 Time: 0.01638 -0.0016876 \n"
"P2243_VELOCITIES #001000 Step: 59 Iteration: 2 Time: 0.01638 -0.0018896 \n"
"P3387_VELOCITIES #001000 Step: 59 Iteration: 2 Time: 0.01638 -0.0016876 \n"
"% of load in interval Step: 59 Iteration: 2 Time: 0.01638 0.0400000 0.0400000 \n"
"summation % of load in interval Step: 59 Iteration: 2 Time: 0.01638 0.0800000 ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")