#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\b[A-ZА-Я](?:[,;:-—’()\w]+? ){3,}\w{2,}[.!?])"
Local $sString = "Medically reviewed by Andrea Hodgson — Written by Susan York Morris — Updated on September 2, 2018" & @CRLF & _
"Introduction" & @CRLF & _
"Тест тест тест тест тест тест тест тест тест." & @CRLF & _
"Kdenfjr - fkefkwfwf kljmlk lklkjol klmlmkl klkoik kjio." & @CRLF & _
"Erectile dysfunction (ED) is a problem with getting and maintaining an erection that’s firm enough to have sexual intercourse. All men have trouble getting an erection from time to time, and the likelihood of this problem increases with age. If it happens to you often, though, you may have ED." & @CRLF & _
"Viagra is a prescription drug that can help men with erectile dysfunction. For many people, romance means candlelight, soft music, and a glass of wine. The little blue pill, Viagra, can be part of this picture, but only if you drink small or moderate amounts of alcohol." & @CRLF & _
"• Market Data" & @CRLF & _
"Currency pairs Find out more about the major currency pairs and what impacts price movements." & @CRLF & _
"Commodities Our guide explores the most traded commodities worldwide and how to start trading them." & @CRLF & _
"Indices Get top insights on the most traded stock indices and what moves indices markets." & @CRLF & _
"Cryptocurrencies Find out more about top cryptocurrencies to trade and how to get started." & @CRLF & _
"• Calendars" & @CRLF & _
"Long Short" & @CRLF & _
"Note: Low and High figures are for the trading day. Data provided by" & @CRLF & _
"Long Short"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")