package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Za-z0-9\s\.\&]+\s+(Place|Terrace|Highway|Road|St?reet?|Road|Lane|Suite|Avenue|Parkway|Court|Boulevard|Rd|Island|Drive|Pike|Floor|St|Falls|Park|Spring|Ave|Drive|Dr|\d+)[.\s]?,?\s?((N|S)?(E|W)?),?[\s0-9\#]*,)(\s[A-Za-z].*,)(\s[A-Za-z\s\.]+)([0-9]+\-?.*)$`)
var str = `3132 10th Street N, Arlington, VA 22201
908 Wahler Place, SE, Washington, DC 20032
2800 Brendan Avenue, Baltimore, MD 21213-1213
533 48th Place, NE, Washington, DC 20019
533 48th Place, NE, Washington, DC 20019
533 48th Place, NE, Washington, DC 20019
800 Poplar Grove Street, Baltimore, MD 21216
1500 Galen Street, SE, Washington, DC 20020
2017 Savannah Terrace, SE, Washington, DC 20032
9000 Richmond Highway, Alexandria, VA 22309
9000 Richmond Highway, Alexandria, VA 22309
9000 Richmond Highway, Alexandria, VA 22309
2400 Bel Pre Road, Silver Spring, MD 20906
2701 S Nelson Street, Arlington, VA 22206
3401 4th Street, SE, Washington, DC 20032
1114 Shawan Road Suite 2, Cockeysville, MD 21030
128 W Franklin Street, Baltimore, MD 21201
1400 W Cold Spring Lane, Baltimore, Maryland 21209
4300 13th Street, NW, Washington, DC 20011
4300 13th Street, NW, Washington, DC 20011
4300 13th Street, NW, Washington, DC 20011
2900 Barclay Street, Baltimore, MD 21218
430 Decatur Street, NW, Washington, DC 20011
6929 Furman Parkway, Riverdale, MD 20737
601 Edgewood Street NE Suite 15, Washington, DC 20017
3600 Alabama Avenue, SE, Washington, DC 20020
3600 Alabama Avenue, SE, Washington, DC 20020
3600 Alabama Avenue, SE, Washington, DC 20020
3754 Martin Luther King Jr. Avenue, SE, Washington, DC 20032
3754 Martin Luther King Jr. Avenue, SE, Washington, DC 20032
3754 Martin Luther King Jr. Avenue, SE, Washington, DC 20032
1406 N Ellamont Street, Baltimore, MD 21216
3640 Martin Luther King Jr. Avenue, SE, Washington, DC 20032
3640 Martin Luther King Jr Avenue, SE, Washington DC 20032
2100 Boone Street, Baltimore, MD 21218
128 M Street NW #150, Washington, DC 20001
1300 Nicholson Street, NW, Washington, DC 20011
3912 Georgia Avenue, NW, Washington, DC 20011
1150 Michigan Avenue, NE, Washington, DC 20017
1150 Michigan Avenue, NE, Washington, DC 20017
18100 Washington Grove Lane, Gaithersburg, MD 20877
3560 Warder Street, NW, Washington, DC 20010
3560 Warder Street, NW, Washington, DC 20010
3560 Warder Street, NW, Washington, DC 20010
1820 Monroe Street, NE, Washington, DC 20018
801 Division Avenue, NE, Washington, DC 20019
801 Division Avenue, NE, Washington, DC 20019
801 Division Avenue, NE, Washington, DC 20019
500 Tristam Court, Baltimore, MD 21208
301 53rd Street, SE, Washington, DC 20019
301 53rd Street, SE, Washington, DC 20019
321 Chrome Road, Rising Sun, MD 21911
16813 Yeoho Road, Sparks, MD 21152
3501 Hillsdale Road, Baltimore, MD 21207
100 Peabody Street NW Floor 1, Washington, DC 20011
601 Suffolk Avenue, Capitol Heights, MD 20743
2118 Ridgecrest Court SE, Washington, DC 20020
100 Peabody Street, NW, Washington, DC 20011
1200 Clifton Street, NW, Washington, DC 20009
1200 Clifton Street, NW, Washington, DC 20009
1200 Clifton Street, NW, Washington, DC 20009
701 Howard Road, SE, Washington, DC 20020
6008 Georgia Avenue, NW, Washington, DC 20011
6008 Georgia Avenue, NW, Washington, DC 20011
1217 West Virginia Avenue, NE, Washington, DC 20002
220 Highview Place, SE, Washington, DC 20032
1217 West Virginia Avenue, NE, Washington, DC 20002
65 Massachusetts Avenue, NW, Washington, DC 20001
1420 Columbia Road, NW, Washington, DC 20009
1345 University Boulevard E, Takoma Park, MD 20912
1420 Columbia Road, NW, Washington, DC 20009
1288 Upshur Street, NW, Washington, DC 20011
325 P Street, SW, Washington, DC 20024
770 Kenyon Street, NW, Washington, DC 20010
6201 Solomons Island Rd., Huntingtown, MD 20639
3720 Martin Luther King Jr. Avenue, SE, Washington, DC 20020
100 Gallatin St. NE 20018
2220 11th Street, NW, Washington, DC 20001
2220 11th Street, NW, Washington, DC 20010
1630 Euclid Street, NW, Washington, DC 20009
111 Michigan Avenue, NW, Washington, DC 20010
2250 Champlain Street, NW, Washington, DC 20009
12500 Wisteria Drive, Germantown, MD 20874
516 Kennedy Street, NW, Washington, DC 20011
1640 Columbia Road, NW, Washington, DC 20009
11904 Old Marlboro Pike, Upper Marlboro, MD 20772
31285 Georgetown Cemetery Road, Georgetown, MD 21930
4 Atlantic Street, SW, Washington, DC 20032
28038 Goldsborough Neck Road, Easton, Maryland 21601
802 S Caroline Street, Baltimore, MD 21231
4301 W Bay Avenue, Baltimore, MD 21225
33 Riggs Road, NE, Washington, DC 20011
5601 E Capitol Street, SE, Washington, DC 20019
33 Riggs Road, NE, Washington, DC 20011
17th & Benning Road, NE, Washington, DC
425 Second Street, NW, Washington, DC 20001
1900 Massachusetts Avenue, SE, Washington, DC 20003
1102 W Street, SE, Washington, DC 20020
1350 49th Street, NE, Washington, DC 20019
3100 Martin Luther King Jr Avenue, SE, Washington, DC 20032
3100 Martin Luther King Jr Avenue, SE, Washington, DC 20032
5241 36th St N, Arlington, VA 22207
53rd Dix Street, NE, Washington, DC 20019
4801 Nannie Helen Burroughs Avenue, NE, Washington, DC 20019
700 Delaware Avenue, SW, Washington, DC 20024
5600 Eads Street, NE, Washington, DC 20019
5600 Eads Street, NE, Washington, DC 20019
5600 Eads Street, NE, Washington, DC 20019
3400 Wheeler Road, SE, Washington, DC 20032
123 45th Street, NE, Washington, DC 20019
1700 East Capitol Street, NE, Washington, DC 20003
1700 E Capitol Street, NE, Washington, DC 20003
2835 Virginia Avenue, Baltimore, MD 21215-6560
3700 Oakview Terrace, NE, Washington, DC 20017
851 Braddish Avenue, Baltimore, MD 21216
3700 Oakview Terrace, NE, Washington, DC 20017
2501 Martin Luther King Jr Avenue, SE, Washington, DC 20020
8115 Gatehouse Road, Falls Church, VA 22042
15290 Purcellville Rd, Purcellville, VA 20132
96 Charles Johnson Farm Lane, Rising Sun, MD 21911
5298 Smoke House Court, Fort Belvoir, VA 22060
3779 Ely Place, SE, Washington, DC 20018
3779 Ely Place, SE, Washington, DC 20018
3779 Ely Place, SE, Washington, DC 20018
1812 Erie Street, SE, Washington, DC 20020
1812 Erie Street, SE, Washington, DC 20020
1812 Erie Street, SE, Washington, DC 20020
3630 Poffenberger Rd, Jefferson, MD 21755
3630 Poffenberger Rd, Jefferson, MD 21755
3630 Poffenberger Rd, Jefferson, MD 21755
3630 Poffenberger Rd, Jefferson, MD 21755
3630 Poffenberger Rd, Jefferson, MD 21755
3630 Poffenberger Rd, Jefferson, MD 21755
2301 Gwynns Falls Parkway, Baltimore, MD 21217-1336
645 Milwaukee Place, SE, Washington, DC 20032
2959 Carlton Avenue, NE, Washington, DC 20018
2959 Carlton Avenue, NE, Washington, DC 20018
2959 Carlton Avenue, NE, Washington, DC 20018
35 North Summit Avenue, Gaithersburg, MD 20877
101 Education Boulevard, Gaithersburg, MD 20877
1649 W Street, SE, Washington, DC 20020
2435 Alabama Avenue, SE, Washington, DC 20020
1200 S Street, NW, Washington, DC 20009
1311 N Gilmor Street, Baltimore, MD 21217-2398
15th Street and Girard Street, NW, Washington, DC 20009
13611 Robey Road, Silver Spring, MD 20904
38223 John Wolford Road, Purcellville, VA 20132
2700 Gwynns Falls Parkway, Baltimore, MD 21216
4605 Martin Luther King Jr Avenue SW, Washington, DC 20032
500 S Linwood Avenue, Baltimore, MD 21224
1401 W Lafayette Avenue, Baltimore, MD 21217
13407 Lydia Street, Silver Spring, MD 20906
601 Mississippi Avenue, SE, Washington, DC 20032
7630 Telegraph Rd, Alexandria, VA 22315
425 Chesapeake Street, SE, Washington, DC 20032
425 Chesapeake Street, SE, Washington, DC 20032
8115 Gatehouse Road, Falls Church, VA 22042
921 Pennsylvania Avenue, SE, Washington, DC 20003
921 Pennsylvania Avenue, SE, Washington, DC 20003
1100 50th Place, NE, Washington, DC 20019
1100 50th Place, NE, Washington, DC 20019
2041 Georgia Avenue, NW, Washington, DC 20060
3500 14th Street, NW, Washington, DC 20010
3924 Minnesota Avenue, NE, Washington, DC 20019
660 K Street, NE, Washington, DC 20002
4130 Albemarle Street, NW, Washington, DC 20016
801 7th Street, SW, Washington, DC 20024
710 Beacon Road, Silver Spring, MD 20903
1820 Monroe Street, NE, Washington, DC 20018
2011 Linden Avenue, Baltimore, MD 21217-4490
111 K Street, NW, Washington, DC 20001
111 K Street, NW, Washington, DC 20001
111 K Street, NW, Washington, DC 20001
301 49th Street, NE, Washington, DC 20019
301 49th Street, NE, Washington, DC 20019
1919 15th Street, SE, Washington, DC 20020
5001 Dana Place, NW, Washington, DC 20016
3375 Minnesota Avenue, SE, Washington, DC 20019
3375 Minnesota Avenue, SE, Washington, DC 20019
2600 Douglass Road, SE, Washington, DC 20020
1375 Mt Olivet Road, NE, Washington, DC 20002
1375 Mt Olivet Road, NE, Washington, DC 20002
1700 Q Street, SE, Washington, DC 20020
1700 Q Street, SE, Washington, DC 20020
1900 Evarts Street, NE, Washington, DC 20018
2901 20th Street, NE, Washington, DC 20018
1098 Delaware Avenue, SW, Washington, DC 20024
501 Riggs Road, NE, Washington, DC 20011
501 Riggs Road, NE, Washington, DC 20011
516 Montgomery Street, Laurel, MD 20707
4201 M.L. King Avenue, SW, Washington, DC 20032
4201 M.L. King Avenue, SW, Washington, DC 20032
3025 4th Street, NE, Washington, DC 20017
400 50th Stree, NE, Washington, DC 20019
400 50th Street, NE, Washington, DC 20018
802 S Caroline Street, Baltimore, MD 21231
PO Box 1521, Great Falls, VA 22066
9000 Richmond Highway, Alexandria, VA 22309
9000 Richmond Highway, Alexandria, VA 22309
301 N Pulaski Street, Baltimore, MD 21223
Woodbine, MD
659 G Street, NE, Washington, DC 20002
1500 Mississippi Avenue, SE, Washington, DC 20032
1500 Mississippi Avenue, SE, Washington, DC 20032
100 Gallatin Street, NE, Washington, DC 20011
4430 Newark Street, NW, Washington, DC 20016
2201 18th Street, NW, Washington, DC 20009
1519 Marion Street, NW, Washington, DC 20001
3200 6th Street, SE, Washington, DC 20032
2405 Tecumseh Street, Adelphi, MD 20783
1404 Jackson Street, NE, Washington, DC 20017
1404 Jackson Street, NE, Washington, DC 20017
1404 Jackson Street, NE, Washington, DC 20017
3912 Georgia Avenue, NW, Washington, DC 20011
2333 Ontario Road, NW, Washington, DC 20009
1305 Rhode Island Avenue, NE, Washington, DC 20018
1000 First Street, Rockville, MD 20850
600 Russell Road, Alexandria, VA 22301
1250 Constitution Avenue, NE, Washington, DC 20002
3744 Hayes Street, NE, Washington, DC 20019
3744 Hayes Street, NE, Washington, DC 20019
4300 Buchanan Avenue, Baltimore, MD 21211
4275 4th Sreet SE, Washington, DC 20032
601 15th Street, NE, Washington, DC 20002
601 15th Street, NE, Washington, DC 20002
2525 Kirk Avenue, Baltimore, MD 21218-4827
807 Daleview Drive, Silver Spring, MD 20901
500 19th Street, NE, Washington, DC 20002
1124 Greenway Road, Cockeysville, MD 21030
1565 Morris Road, SE, Washington, DC 20020
11661 Harpers Ferry Road, Purcellville, VA 20132
121 McMechen Street, Baltimore, MD 21217
8515 Old Mount Vernon Road, Alexandria, VA 22309
4015 Fielding Street, Alexandria, VA 22309
30 P Street, NW, Washington, DC 20001
30 P Street, NW, Washington, DC 20001
3373 Van Ness Street, NW, Washington, DC 20008
1333 N Street, NW, Washingont, DC 20005
219 50th Street, SE, Washington, DC 20019
219 50th Street, SE, Washington, DC 20019
3675 Ely Place, SE, Washington, DC 20019
20633 Mount Zion Road, Freeland, MD 21053
1114 Shawan Road Suite 1, Cockeysville, MD 21030
18608 Wasche Road, Dickerson, MD 20842
6600 B Roy Shafer Road, Middletown, MD 21769
3598 Hayes Street, NE, Washington, DC 20019
3551 Jay Street, NE, DC 20019
3513 Jay Street, NE, Washington, DC 20019
4399 South Capitol Terrace, SW, Washington, DC 20032
100 Kane Street, Baltimore, MD 21224
425 C Street, NE, Washington, DC 20002
7510 Maple Avenue, Takoma Park, MD 20912
4601 Texas Avenue, SE, Washington, DC 20019
5996 Augustine Herman Highway, Cecilton, MD 21913
3754 Martin Luther King Jr. Avenue, SE, Washington, DC 20032
1650 30th Street, SE, Washington, DC 20020
915 Spring Road, NW, Washington, DC 20010
3725 10th Street, NW, Washington, DC 20010
2701 Saint Louis Drive, Baltimore, MD 21213
2801 Saint Lo Drive, Baltimore, MD 21213
23400 Ridge Road, Germantown, MD 20876
23400 Ridge Road, Germantown, MD 20876
23400 Ridge Road, Germantown, MD 20876
405 Anacostia Avenue, NE, Washington, DC 20019
405 Anacostia Avenue, NE, Washington, DC 20019
8410 Old Mount Vernon Road, Alexandria, VA 22309
2335 Raynolds Place, SE, Washington, DC 20020
4300 Sidehill Road, Baltimore, MD 21229-1595
705 Bayfield Street Takoma Park, MD 20912
4800 Meade Street, NE, Washington, DC 20019
424 S Pulaski Street, Baltimore, MD 21223
12518 Greenly Street Silver Spring, Maryland, MD 20906
23217 Bayside Road, Leonardtown, MD 20650
2400 Shannon Place, SE, Washington, DC 20020
920 F Street, NE, Washington, DC 20002
2425 N Street, NW, Washington, DC 20037
1503 10th Street, NW, Washington, DC 20001
1503 10th Street, NW, Washington, DC 20001
1503 10th Street, NW, Washington, DC 20001
150 W West Street, Baltimore, MD 21230
401 Mississippi Avenue, SE, Washington, DC 20032
1401 Dennis Avenue, Silver Spring, MD 20902
4400 Brooks Street, NE, Washington, DC 20019
4400 Brooks Street, NE, Washington, DC 20019
4400 Brooks Street, NE, Washington, DC 20019
2025 Fendall Street, SE, Washington, DC 20003
2765 Naylor Road, SE, Washington, DC 20020
60 O Street, NW, Washington, DC 20001
740 Barnaby Street, SE, Washington, DC 20032
2025 Fendall Street, SE, Washington, DC 20003
2025 Fendall Street, SE, Washington, DC 20003
2765 Naylor Road, SE, Washington, DC 20020
2765 Naylor Road, SE, Washington, DC 20020
3650 Ely Place, SE, Washington, DC 20019
850 Delaware Avenue, SW, Washington, DC 20024
2701 Naylor Road, SE, Washington, DC 20020
2701 Naylor Road, SE, Washington, DC 20020
2701 Naylor Road, SE, Washington, DC 20020
4001 Calvert Street, NW, Washington, DC 20007
7010 Piney Branch Road, NW, Washington, DC 20012
15855 Limestone School Road, Leesburg, VA 20176
6001 Carters Lane, Riverdale, MD 20737
301 49th Street, NE, Washington, DC 20019
5623 McClean Boulevard, Baltimore, MD 21214
180 High Park Lane, Silver Spring, MD 20910
650 Maskell Street, Alexandria, VA 22301
1901 Mississippi Avenue, SE, Washington, DC 20020
1901 Mississippi Avenue, SE, Washington, DC 20020
1901 Mississippi Avenue, SE, Washington, DC 20020
650 Anacostia Avenue, NE, Washington, DC 20019
650 Anacostia Avenue, NE, Washington, DC 20019
650 Anacostia Avenue, NE, Washington, DC 20019
1200 L Street, NW, Washington, DC 20005
1200 L Street, NW, Washington, DC 20005
3104 4th Street, NE, Washington, DC 20017
800 Ingraham Street, NW, Washington, DC 20011
800 Ingraham Street, NW, Washington, DC 20011
5504 York Road, Baltimore, MD 21212-3805
3264 Stanton Road, SE, Washington, DC 20020
3264 Stanton Road, SE, Washington, DC 20020
4226 Maple Grove Road, Hampstead, MD 21074
1001 G Street, SE, Washington, DC 20003
1310 Southern Avenue, SE, Washington, DC 20032
3020 14th Street, NW, Washington, DC 20009
3020 14th Street, NW, Washington, DC 20009
3924 Minnesota Avenue, NE, Washington, DC 20019
3924 Minnesota Avenue, NE, Washington, DC 20019
765 Kenilworth Terrace, NE, Washington, DC 20019
3020 14th Street, NW, Washington, DC 20009
40 Patterson Street, NE, Washington, DC 20002
765 Kenilworth Terrace, NE, Washington, DC 20019
2123 Jull Hall University of Maryland 4196 Stadium Drive, College Park, MD 20742
3020 14th Street, NW, Washington, DC 20009
3403 16th Street, NW, Washington, DC 20010
1100 5th Street, SE, Washington, DC 20003
239 Harry S. Truman Drive., Largo, MD 20774
9311 Gaither Road, Gaithersburg, MD 20877
1125 New Jersey Avenue, NW, Washington, DC 20001
40 Patterson Street, NE, Washington, DC 20002
2500 Parkers Lane, Alexandria, VA 22306-3208
900 Varnum Street, NE, Washington, DC 20017
1920 Bladensburg Road, NE, Washington, DC 20002
9100 Cherrytree Drive, Alexandria, VA 22309
1901 Mississippi Avenue, SE, #203 Washington, DC 20020
1901 Mississippi Avenue, SE, #203 Washington, DC 20020
1604 Morris Road, SE, Washington, DC 20020
1604 Morris Road, SE, Washington, DC 20020
3501 New York Ave NE, Washington, DC 20002
3501 New York Avenue, NE, Washington, DC 20002
220 Taylor Street, NE, Washington, DC 20017
420 12th Street, SE, Washington, DC 20003
1338 Farragut Street, NW, Washington, DC 20011
4510 Faroe Place, Rockville, MD 20853
930 Whitelock Street, Baltimore, MD 21217
23595 Founders Drive, Ashburn, VA 20148
23595 Founders Drive, Ashburn, VA 20148
4001 Alto Road, Baltimore, MD 21216
8505 Highland Lane, Alexandria, VA 22309
8718 Old Mount Vernon Road, Alexandria, VA 22309
1801 Hamlin Street, NE, Washington, DC 20018
3950 Chesapeake Street, NW, Washington, DC 20016
1325 W Street, NW, Washington, DC 20009
1906 Allison Street, NE, Washington, DC 20018
2118 Ridgecrest Court, SE, Washington, DC 20020
1500 N Glebe Road, Arlington, VA 22207
900 Massachusetts Avenue, NW, Washington, DC 20001
219 Riggs Road, NE, Washington, DC 20011
900 Massachusetts Avenue, NW, Washington, DC 20001
4900 Puerto Rico Avenue, NE, Washington, DC 20017
1525 Newton Street, NW, Washington, DC 20010
755 8th Street, NW, Washington, DC 20001
4913 Crittenden Street, Edmonston, MD 20781
6100 Emerson Street, Bladensburg, MD 20710
4913 Crittenden Street, Edmonston, MD 20781
6100 Emerson Street, Bladensburg, MD 20710
4900 Puerto Rico Avenue NE, Washington, D.C. 20017
4900 Puerto Rico Avenue, NE, Washington, DC 20017
6100 Emerson Street, Bladensburg, MD 20710
4900 Puerto Rico Avenue, NE, Washington, DC 20017
2006 Rhode Island Avenue, NE, Washington, DC 20018
4900 Puerto Rico Avenue, NE, Washington, DC 20017
4913 Crittenden Street, Edmonston, MD 20781
1369 New York Avenue, NE, Washington, DC 20002
755 8th Street, NW, Washington, DC 20001
900 Massachusetts Avenue, NW, Washington, DC 20001
Kenyon Street and Park Place, NW, Washington, DC 20010
640 Anacostia Avenue NE, Washington, DC 20019
5506 3rd St. NW, Washington, DC 20011
1202 Kennedy St. NW, Washington, DC 20011
6200 Kansas Ave. NE, Washington, DC 20011
1017 New Jersey Ave. SE, Washington, DC 20003
1400 Main Dr. NW, Washington, DC 20012
4800 Auburn Ave, Bethesda, MD 20814
300 V St NW, Washington, D.C. 20001
212 South Washington Street, Alexandria, VA 22314
3400 Wheeler Rd SE, Washington, DC 20032`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}