import re
regex = re.compile(r"^([A-Za-z0-9\s\.\&]+\s+(Place|Terrace|Highway|Road|St?reet?|Road|Lane|Suite|Avenue|Parkway|Court|Boulevard|Rd|Island|Drive|Pike|Floor|St|Falls|Park|Spring|Ave|Drive|Dr|\d+)[.\s]?,?\s?((N|S)?(E|W)?),?[\s0-9\#]*,)(\s[A-Za-z].*,)(\s[A-Za-z\s\.]+)([0-9]+\-?.*)$", flags=re.MULTILINE)
test_str = ("3132 10th Street N, Arlington, VA 22201\n"
"908 Wahler Place, SE, Washington, DC 20032\n"
"2800 Brendan Avenue, Baltimore, MD 21213-1213\n"
"533 48th Place, NE, Washington, DC 20019\n"
"533 48th Place, NE, Washington, DC 20019\n"
"533 48th Place, NE, Washington, DC 20019\n"
"800 Poplar Grove Street, Baltimore, MD 21216\n"
"1500 Galen Street, SE, Washington, DC 20020\n"
"2017 Savannah Terrace, SE, Washington, DC 20032\n"
"9000 Richmond Highway, Alexandria, VA 22309\n"
"9000 Richmond Highway, Alexandria, VA 22309\n"
"9000 Richmond Highway, Alexandria, VA 22309\n"
"2400 Bel Pre Road, Silver Spring, MD 20906\n"
"2701 S Nelson Street, Arlington, VA 22206\n"
"3401 4th Street, SE, Washington, DC 20032\n"
"1114 Shawan Road Suite 2, Cockeysville, MD 21030\n"
"128 W Franklin Street, Baltimore, MD 21201\n"
"1400 W Cold Spring Lane, Baltimore, Maryland 21209\n"
"4300 13th Street, NW, Washington, DC 20011\n"
"4300 13th Street, NW, Washington, DC 20011\n"
"4300 13th Street, NW, Washington, DC 20011\n"
"2900 Barclay Street, Baltimore, MD 21218\n"
"430 Decatur Street, NW, Washington, DC 20011\n"
"6929 Furman Parkway, Riverdale, MD 20737\n"
"601 Edgewood Street NE Suite 15, Washington, DC 20017\n"
"3600 Alabama Avenue, SE, Washington, DC 20020\n"
"3600 Alabama Avenue, SE, Washington, DC 20020\n"
"3600 Alabama Avenue, SE, Washington, DC 20020\n"
"3754 Martin Luther King Jr. Avenue, SE, Washington, DC 20032\n"
"3754 Martin Luther King Jr. Avenue, SE, Washington, DC 20032\n"
"3754 Martin Luther King Jr. Avenue, SE, Washington, DC 20032\n"
"1406 N Ellamont Street, Baltimore, MD 21216\n"
"3640 Martin Luther King Jr. Avenue, SE, Washington, DC 20032\n"
"3640 Martin Luther King Jr Avenue, SE, Washington DC 20032\n"
"2100 Boone Street, Baltimore, MD 21218\n"
"128 M Street NW #150, Washington, DC 20001\n"
"1300 Nicholson Street, NW, Washington, DC 20011\n"
"3912 Georgia Avenue, NW, Washington, DC 20011\n"
"1150 Michigan Avenue, NE, Washington, DC 20017\n"
"1150 Michigan Avenue, NE, Washington, DC 20017\n"
"18100 Washington Grove Lane, Gaithersburg, MD 20877\n"
"3560 Warder Street, NW, Washington, DC 20010\n"
"3560 Warder Street, NW, Washington, DC 20010\n"
"3560 Warder Street, NW, Washington, DC 20010\n"
"1820 Monroe Street, NE, Washington, DC 20018\n"
"801 Division Avenue, NE, Washington, DC 20019\n"
"801 Division Avenue, NE, Washington, DC 20019\n"
"801 Division Avenue, NE, Washington, DC 20019\n"
"500 Tristam Court, Baltimore, MD 21208\n"
"301 53rd Street, SE, Washington, DC 20019\n"
"301 53rd Street, SE, Washington, DC 20019\n"
"321 Chrome Road, Rising Sun, MD 21911\n"
"16813 Yeoho Road, Sparks, MD 21152\n"
"3501 Hillsdale Road, Baltimore, MD 21207\n"
"100 Peabody Street NW Floor 1, Washington, DC 20011\n"
"601 Suffolk Avenue, Capitol Heights, MD 20743\n"
"2118 Ridgecrest Court SE, Washington, DC 20020\n"
"100 Peabody Street, NW, Washington, DC 20011\n"
"1200 Clifton Street, NW, Washington, DC 20009\n"
"1200 Clifton Street, NW, Washington, DC 20009\n"
"1200 Clifton Street, NW, Washington, DC 20009\n"
"701 Howard Road, SE, Washington, DC 20020\n"
"6008 Georgia Avenue, NW, Washington, DC 20011\n"
"6008 Georgia Avenue, NW, Washington, DC 20011\n"
"1217 West Virginia Avenue, NE, Washington, DC 20002\n"
"220 Highview Place, SE, Washington, DC 20032\n"
"1217 West Virginia Avenue, NE, Washington, DC 20002\n"
"65 Massachusetts Avenue, NW, Washington, DC 20001\n"
"1420 Columbia Road, NW, Washington, DC 20009\n"
"1345 University Boulevard E, Takoma Park, MD 20912\n"
"1420 Columbia Road, NW, Washington, DC 20009\n"
"1288 Upshur Street, NW, Washington, DC 20011\n"
"325 P Street, SW, Washington, DC 20024\n"
"770 Kenyon Street, NW, Washington, DC 20010\n"
"6201 Solomons Island Rd., Huntingtown, MD 20639\n"
"3720 Martin Luther King Jr. Avenue, SE, Washington, DC 20020\n"
"100 Gallatin St. NE 20018\n"
"2220 11th Street, NW, Washington, DC 20001\n"
"2220 11th Street, NW, Washington, DC 20010\n"
"1630 Euclid Street, NW, Washington, DC 20009\n"
"111 Michigan Avenue, NW, Washington, DC 20010\n"
"2250 Champlain Street, NW, Washington, DC 20009\n"
"12500 Wisteria Drive, Germantown, MD 20874\n"
"516 Kennedy Street, NW, Washington, DC 20011\n"
"1640 Columbia Road, NW, Washington, DC 20009\n"
"11904 Old Marlboro Pike, Upper Marlboro, MD 20772\n"
"31285 Georgetown Cemetery Road, Georgetown, MD 21930\n"
"4 Atlantic Street, SW, Washington, DC 20032\n"
"28038 Goldsborough Neck Road, Easton, Maryland 21601\n"
"802 S Caroline Street, Baltimore, MD 21231\n"
"4301 W Bay Avenue, Baltimore, MD 21225\n"
"33 Riggs Road, NE, Washington, DC 20011\n"
"5601 E Capitol Street, SE, Washington, DC 20019\n"
"33 Riggs Road, NE, Washington, DC 20011\n"
"17th & Benning Road, NE, Washington, DC\n"
"425 Second Street, NW, Washington, DC 20001\n"
"1900 Massachusetts Avenue, SE, Washington, DC 20003\n"
"1102 W Street, SE, Washington, DC 20020\n"
"1350 49th Street, NE, Washington, DC 20019\n"
"3100 Martin Luther King Jr Avenue, SE, Washington, DC 20032\n"
"3100 Martin Luther King Jr Avenue, SE, Washington, DC 20032\n"
"5241 36th St N, Arlington, VA 22207\n"
"53rd Dix Street, NE, Washington, DC 20019\n"
"4801 Nannie Helen Burroughs Avenue, NE, Washington, DC 20019\n"
"700 Delaware Avenue, SW, Washington, DC 20024\n"
"5600 Eads Street, NE, Washington, DC 20019\n"
"5600 Eads Street, NE, Washington, DC 20019\n"
"5600 Eads Street, NE, Washington, DC 20019\n"
"3400 Wheeler Road, SE, Washington, DC 20032\n"
"123 45th Street, NE, Washington, DC 20019\n"
"1700 East Capitol Street, NE, Washington, DC 20003\n"
"1700 E Capitol Street, NE, Washington, DC 20003\n"
"2835 Virginia Avenue, Baltimore, MD 21215-6560\n"
"3700 Oakview Terrace, NE, Washington, DC 20017 \n"
"851 Braddish Avenue, Baltimore, MD 21216\n"
"3700 Oakview Terrace, NE, Washington, DC 20017\n"
"2501 Martin Luther King Jr Avenue, SE, Washington, DC 20020\n"
"8115 Gatehouse Road, Falls Church, VA 22042\n"
"15290 Purcellville Rd, Purcellville, VA 20132\n"
"96 Charles Johnson Farm Lane, Rising Sun, MD 21911\n"
"5298 Smoke House Court, Fort Belvoir, VA 22060\n"
"3779 Ely Place, SE, Washington, DC 20018 \n"
"3779 Ely Place, SE, Washington, DC 20018 \n"
"3779 Ely Place, SE, Washington, DC 20018 \n"
"1812 Erie Street, SE, Washington, DC 20020\n"
"1812 Erie Street, SE, Washington, DC 20020\n"
"1812 Erie Street, SE, Washington, DC 20020\n"
"3630 Poffenberger Rd, Jefferson, MD 21755\n"
"3630 Poffenberger Rd, Jefferson, MD 21755\n"
"3630 Poffenberger Rd, Jefferson, MD 21755\n"
"3630 Poffenberger Rd, Jefferson, MD 21755\n"
"3630 Poffenberger Rd, Jefferson, MD 21755\n"
"3630 Poffenberger Rd, Jefferson, MD 21755\n"
"2301 Gwynns Falls Parkway, Baltimore, MD 21217-1336\n"
"645 Milwaukee Place, SE, Washington, DC 20032\n"
"2959 Carlton Avenue, NE, Washington, DC 20018\n"
"2959 Carlton Avenue, NE, Washington, DC 20018\n"
"2959 Carlton Avenue, NE, Washington, DC 20018\n"
"35 North Summit Avenue, Gaithersburg, MD 20877\n"
"101 Education Boulevard, Gaithersburg, MD 20877\n"
"1649 W Street, SE, Washington, DC 20020\n"
"2435 Alabama Avenue, SE, Washington, DC 20020\n"
"1200 S Street, NW, Washington, DC 20009\n"
"1311 N Gilmor Street, Baltimore, MD 21217-2398\n"
"15th Street and Girard Street, NW, Washington, DC 20009 \n"
"13611 Robey Road, Silver Spring, MD 20904\n"
"38223 John Wolford Road, Purcellville, VA 20132\n"
"2700 Gwynns Falls Parkway, Baltimore, MD 21216\n"
"4605 Martin Luther King Jr Avenue SW, Washington, DC 20032\n"
"500 S Linwood Avenue, Baltimore, MD 21224\n"
"1401 W Lafayette Avenue, Baltimore, MD 21217\n"
"13407 Lydia Street, Silver Spring, MD 20906\n"
"601 Mississippi Avenue, SE, Washington, DC 20032\n"
"7630 Telegraph Rd, Alexandria, VA 22315\n"
"425 Chesapeake Street, SE, Washington, DC 20032\n"
"425 Chesapeake Street, SE, Washington, DC 20032\n"
"8115 Gatehouse Road, Falls Church, VA 22042\n"
"921 Pennsylvania Avenue, SE, Washington, DC 20003\n"
"921 Pennsylvania Avenue, SE, Washington, DC 20003\n"
"1100 50th Place, NE, Washington, DC 20019\n"
"1100 50th Place, NE, Washington, DC 20019\n"
"2041 Georgia Avenue, NW, Washington, DC 20060\n"
"3500 14th Street, NW, Washington, DC 20010\n"
"3924 Minnesota Avenue, NE, Washington, DC 20019\n"
"660 K Street, NE, Washington, DC 20002\n"
"4130 Albemarle Street, NW, Washington, DC 20016\n"
"801 7th Street, SW, Washington, DC 20024\n"
"710 Beacon Road, Silver Spring, MD 20903\n"
"1820 Monroe Street, NE, Washington, DC 20018 \n"
"2011 Linden Avenue, Baltimore, MD 21217-4490\n"
"111 K Street, NW, Washington, DC 20001\n"
"111 K Street, NW, Washington, DC 20001\n"
"111 K Street, NW, Washington, DC 20001\n"
"301 49th Street, NE, Washington, DC 20019\n"
"301 49th Street, NE, Washington, DC 20019\n"
"1919 15th Street, SE, Washington, DC 20020\n"
"5001 Dana Place, NW, Washington, DC 20016\n"
"3375 Minnesota Avenue, SE, Washington, DC 20019\n"
"3375 Minnesota Avenue, SE, Washington, DC 20019\n"
"2600 Douglass Road, SE, Washington, DC 20020\n"
"1375 Mt Olivet Road, NE, Washington, DC 20002\n"
"1375 Mt Olivet Road, NE, Washington, DC 20002\n"
"1700 Q Street, SE, Washington, DC 20020\n"
"1700 Q Street, SE, Washington, DC 20020\n"
"1900 Evarts Street, NE, Washington, DC 20018\n"
"2901 20th Street, NE, Washington, DC 20018\n"
"1098 Delaware Avenue, SW, Washington, DC 20024\n"
"501 Riggs Road, NE, Washington, DC 20011\n"
"501 Riggs Road, NE, Washington, DC 20011\n"
"516 Montgomery Street, Laurel, MD 20707\n"
"4201 M.L. King Avenue, SW, Washington, DC 20032\n"
"4201 M.L. King Avenue, SW, Washington, DC 20032\n"
"3025 4th Street, NE, Washington, DC 20017\n"
"400 50th Stree, NE, Washington, DC 20019\n"
"400 50th Street, NE, Washington, DC 20018\n"
"802 S Caroline Street, Baltimore, MD 21231\n"
"PO Box 1521, Great Falls, VA 22066\n"
"9000 Richmond Highway, Alexandria, VA 22309\n"
"9000 Richmond Highway, Alexandria, VA 22309\n"
"301 N Pulaski Street, Baltimore, MD 21223\n"
"Woodbine, MD\n"
"659 G Street, NE, Washington, DC 20002\n"
"1500 Mississippi Avenue, SE, Washington, DC 20032\n"
"1500 Mississippi Avenue, SE, Washington, DC 20032\n"
"100 Gallatin Street, NE, Washington, DC 20011\n"
"4430 Newark Street, NW, Washington, DC 20016\n"
"2201 18th Street, NW, Washington, DC 20009\n"
"1519 Marion Street, NW, Washington, DC 20001 \n"
"3200 6th Street, SE, Washington, DC 20032\n"
"2405 Tecumseh Street, Adelphi, MD 20783\n"
"1404 Jackson Street, NE, Washington, DC 20017 \n"
"1404 Jackson Street, NE, Washington, DC 20017\n"
"1404 Jackson Street, NE, Washington, DC 20017\n"
"3912 Georgia Avenue, NW, Washington, DC 20011\n"
"2333 Ontario Road, NW, Washington, DC 20009\n"
"1305 Rhode Island Avenue, NE, Washington, DC 20018\n"
"1000 First Street, Rockville, MD 20850\n"
"600 Russell Road, Alexandria, VA 22301\n"
"1250 Constitution Avenue, NE, Washington, DC 20002\n"
"3744 Hayes Street, NE, Washington, DC 20019\n"
"3744 Hayes Street, NE, Washington, DC 20019\n"
"4300 Buchanan Avenue, Baltimore, MD 21211\n"
"4275 4th Sreet SE, Washington, DC 20032\n"
"601 15th Street, NE, Washington, DC 20002\n"
"601 15th Street, NE, Washington, DC 20002\n"
"2525 Kirk Avenue, Baltimore, MD 21218-4827\n"
"807 Daleview Drive, Silver Spring, MD 20901\n"
"500 19th Street, NE, Washington, DC 20002\n"
"1124 Greenway Road, Cockeysville, MD 21030\n"
"1565 Morris Road, SE, Washington, DC 20020\n"
"11661 Harpers Ferry Road, Purcellville, VA 20132\n"
"121 McMechen Street, Baltimore, MD 21217\n"
"8515 Old Mount Vernon Road, Alexandria, VA 22309\n"
"4015 Fielding Street, Alexandria, VA 22309\n"
"30 P Street, NW, Washington, DC 20001\n"
"30 P Street, NW, Washington, DC 20001\n"
"3373 Van Ness Street, NW, Washington, DC 20008\n"
"1333 N Street, NW, Washingont, DC 20005\n"
"219 50th Street, SE, Washington, DC 20019\n"
"219 50th Street, SE, Washington, DC 20019\n"
"3675 Ely Place, SE, Washington, DC 20019\n"
"20633 Mount Zion Road, Freeland, MD 21053\n"
"1114 Shawan Road Suite 1, Cockeysville, MD 21030\n"
"18608 Wasche Road, Dickerson, MD 20842\n"
"6600 B Roy Shafer Road, Middletown, MD 21769\n"
"3598 Hayes Street, NE, Washington, DC 20019\n"
"3551 Jay Street, NE, DC 20019\n"
"3513 Jay Street, NE, Washington, DC 20019 \n"
"4399 South Capitol Terrace, SW, Washington, DC 20032\n"
"100 Kane Street, Baltimore, MD 21224\n"
"425 C Street, NE, Washington, DC 20002\n"
"7510 Maple Avenue, Takoma Park, MD 20912\n"
"4601 Texas Avenue, SE, Washington, DC 20019\n"
"5996 Augustine Herman Highway, Cecilton, MD 21913\n"
"3754 Martin Luther King Jr. Avenue, SE, Washington, DC 20032\n"
"1650 30th Street, SE, Washington, DC 20020\n"
"915 Spring Road, NW, Washington, DC 20010\n"
"3725 10th Street, NW, Washington, DC 20010\n"
"2701 Saint Louis Drive, Baltimore, MD 21213\n"
"2801 Saint Lo Drive, Baltimore, MD 21213\n"
"23400 Ridge Road, Germantown, MD 20876\n"
"23400 Ridge Road, Germantown, MD 20876\n"
"23400 Ridge Road, Germantown, MD 20876\n"
"405 Anacostia Avenue, NE, Washington, DC 20019\n"
"405 Anacostia Avenue, NE, Washington, DC 20019\n"
"8410 Old Mount Vernon Road, Alexandria, VA 22309\n"
"2335 Raynolds Place, SE, Washington, DC 20020\n"
"4300 Sidehill Road, Baltimore, MD 21229-1595\n"
"705 Bayfield Street Takoma Park, MD 20912\n"
"4800 Meade Street, NE, Washington, DC 20019\n"
"424 S Pulaski Street, Baltimore, MD 21223\n"
"12518 Greenly Street Silver Spring, Maryland, MD 20906\n"
"23217 Bayside Road, Leonardtown, MD 20650\n"
"2400 Shannon Place, SE, Washington, DC 20020\n"
"920 F Street, NE, Washington, DC 20002\n"
"2425 N Street, NW, Washington, DC 20037\n"
"1503 10th Street, NW, Washington, DC 20001\n"
"1503 10th Street, NW, Washington, DC 20001\n"
"1503 10th Street, NW, Washington, DC 20001\n"
"150 W West Street, Baltimore, MD 21230\n"
"401 Mississippi Avenue, SE, Washington, DC 20032\n"
"1401 Dennis Avenue, Silver Spring, MD 20902\n"
"4400 Brooks Street, NE, Washington, DC 20019\n"
"4400 Brooks Street, NE, Washington, DC 20019\n"
"4400 Brooks Street, NE, Washington, DC 20019\n"
"2025 Fendall Street, SE, Washington, DC 20003\n"
"2765 Naylor Road, SE, Washington, DC 20020\n"
"60 O Street, NW, Washington, DC 20001\n"
"740 Barnaby Street, SE, Washington, DC 20032\n"
"2025 Fendall Street, SE, Washington, DC 20003\n"
"2025 Fendall Street, SE, Washington, DC 20003\n"
"2765 Naylor Road, SE, Washington, DC 20020\n"
"2765 Naylor Road, SE, Washington, DC 20020\n"
"3650 Ely Place, SE, Washington, DC 20019\n"
"850 Delaware Avenue, SW, Washington, DC 20024\n"
"2701 Naylor Road, SE, Washington, DC 20020\n"
"2701 Naylor Road, SE, Washington, DC 20020\n"
"2701 Naylor Road, SE, Washington, DC 20020\n"
"4001 Calvert Street, NW, Washington, DC 20007\n"
"7010 Piney Branch Road, NW, Washington, DC 20012\n"
"15855 Limestone School Road, Leesburg, VA 20176\n"
"6001 Carters Lane, Riverdale, MD 20737\n"
"301 49th Street, NE, Washington, DC 20019\n"
"5623 McClean Boulevard, Baltimore, MD 21214\n"
"180 High Park Lane, Silver Spring, MD 20910\n"
"650 Maskell Street, Alexandria, VA 22301\n"
"1901 Mississippi Avenue, SE, Washington, DC 20020\n"
"1901 Mississippi Avenue, SE, Washington, DC 20020\n"
"1901 Mississippi Avenue, SE, Washington, DC 20020\n"
"650 Anacostia Avenue, NE, Washington, DC 20019\n"
"650 Anacostia Avenue, NE, Washington, DC 20019\n"
"650 Anacostia Avenue, NE, Washington, DC 20019\n"
"1200 L Street, NW, Washington, DC 20005\n"
"1200 L Street, NW, Washington, DC 20005\n"
"3104 4th Street, NE, Washington, DC 20017\n"
"800 Ingraham Street, NW, Washington, DC 20011\n"
"800 Ingraham Street, NW, Washington, DC 20011\n"
"5504 York Road, Baltimore, MD 21212-3805\n"
"3264 Stanton Road, SE, Washington, DC 20020\n"
"3264 Stanton Road, SE, Washington, DC 20020\n"
"4226 Maple Grove Road, Hampstead, MD 21074\n"
"1001 G Street, SE, Washington, DC 20003\n"
"1310 Southern Avenue, SE, Washington, DC 20032\n"
"3020 14th Street, NW, Washington, DC 20009\n"
"3020 14th Street, NW, Washington, DC 20009\n"
"3924 Minnesota Avenue, NE, Washington, DC 20019\n"
"3924 Minnesota Avenue, NE, Washington, DC 20019\n"
"765 Kenilworth Terrace, NE, Washington, DC 20019\n"
"3020 14th Street, NW, Washington, DC 20009\n"
"40 Patterson Street, NE, Washington, DC 20002\n"
"765 Kenilworth Terrace, NE, Washington, DC 20019\n"
"2123 Jull Hall University of Maryland 4196 Stadium Drive, College Park, MD 20742\n"
"3020 14th Street, NW, Washington, DC 20009\n"
"3403 16th Street, NW, Washington, DC 20010\n"
"1100 5th Street, SE, Washington, DC 20003\n"
"239 Harry S. Truman Drive., Largo, MD 20774\n"
"9311 Gaither Road, Gaithersburg, MD 20877\n"
"1125 New Jersey Avenue, NW, Washington, DC 20001\n"
"40 Patterson Street, NE, Washington, DC 20002\n"
"2500 Parkers Lane, Alexandria, VA 22306-3208\n"
"900 Varnum Street, NE, Washington, DC 20017 \n"
"1920 Bladensburg Road, NE, Washington, DC 20002\n"
"9100 Cherrytree Drive, Alexandria, VA 22309\n"
"1901 Mississippi Avenue, SE, #203 Washington, DC 20020\n"
"1901 Mississippi Avenue, SE, #203 Washington, DC 20020\n"
"1604 Morris Road, SE, Washington, DC 20020\n"
"1604 Morris Road, SE, Washington, DC 20020\n"
"3501 New York Ave NE, Washington, DC 20002\n"
"3501 New York Avenue, NE, Washington, DC 20002\n"
"220 Taylor Street, NE, Washington, DC 20017\n"
"420 12th Street, SE, Washington, DC 20003\n"
"1338 Farragut Street, NW, Washington, DC 20011\n"
"4510 Faroe Place, Rockville, MD 20853\n"
"930 Whitelock Street, Baltimore, MD 21217\n"
"23595 Founders Drive, Ashburn, VA 20148\n"
"23595 Founders Drive, Ashburn, VA 20148\n"
"4001 Alto Road, Baltimore, MD 21216\n"
"8505 Highland Lane, Alexandria, VA 22309\n"
"8718 Old Mount Vernon Road, Alexandria, VA 22309\n"
"1801 Hamlin Street, NE, Washington, DC 20018\n"
"3950 Chesapeake Street, NW, Washington, DC 20016\n"
"1325 W Street, NW, Washington, DC 20009\n"
"1906 Allison Street, NE, Washington, DC 20018\n"
"2118 Ridgecrest Court, SE, Washington, DC 20020\n"
"1500 N Glebe Road, Arlington, VA 22207\n"
"900 Massachusetts Avenue, NW, Washington, DC 20001\n"
"219 Riggs Road, NE, Washington, DC 20011\n"
"900 Massachusetts Avenue, NW, Washington, DC 20001\n"
"4900 Puerto Rico Avenue, NE, Washington, DC 20017\n"
"1525 Newton Street, NW, Washington, DC 20010\n"
"755 8th Street, NW, Washington, DC 20001\n"
"4913 Crittenden Street, Edmonston, MD 20781\n"
"6100 Emerson Street, Bladensburg, MD 20710\n"
"4913 Crittenden Street, Edmonston, MD 20781\n"
"6100 Emerson Street, Bladensburg, MD 20710\n"
"4900 Puerto Rico Avenue NE, Washington, D.C. 20017\n"
"4900 Puerto Rico Avenue, NE, Washington, DC 20017\n"
"6100 Emerson Street, Bladensburg, MD 20710\n"
"4900 Puerto Rico Avenue, NE, Washington, DC 20017\n"
"2006 Rhode Island Avenue, NE, Washington, DC 20018\n"
"4900 Puerto Rico Avenue, NE, Washington, DC 20017\n"
"4913 Crittenden Street, Edmonston, MD 20781\n"
"1369 New York Avenue, NE, Washington, DC 20002 \n"
"755 8th Street, NW, Washington, DC 20001\n"
"900 Massachusetts Avenue, NW, Washington, DC 20001\n"
"Kenyon Street and Park Place, NW, Washington, DC 20010\n"
"640 Anacostia Avenue NE, Washington, DC 20019\n"
"5506 3rd St. NW, Washington, DC 20011\n"
"1202 Kennedy St. NW, Washington, DC 20011\n"
"6200 Kansas Ave. NE, Washington, DC 20011\n"
"1017 New Jersey Ave. SE, Washington, DC 20003\n"
"1400 Main Dr. NW, Washington, DC 20012\n\n"
"4800 Auburn Ave, Bethesda, MD 20814\n"
"300 V St NW, Washington, D.C. 20001\n"
"212 South Washington Street, Alexandria, VA 22314\n"
"3400 Wheeler Rd SE, Washington, DC 20032")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")