$re = '/^[0-9]+(?:,[0-9]+)*$/m';
$str = '1,2,3
1
1,2,
11,2,3443,ed
11,2,33,1322
11,3,,
11,34234,
,,,,1,,2dgd,d,
1,2,3,
,1,2,,,3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);