// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9]+(?:,[0-9]+)*$").unwrap();
let string = "1,2,3
1
1,2,
11,2,3443,ed
11,2,33,1322
11,3,,
11,34234,
,,,,1,,2dgd,d,
1,2,3,
,1,2,,,3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}