package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(ZB[\w\-]*)`)
var str = `ZP-S,ZB-MA-S,ZB,ZB-MA-M,ZB-MA-B,ZP,PY,ZB-ME-S,ZB-ME-M,PY,ZB-ME-B,PY-S,PY-M,PY-B,ZP-B,ZB-MA-S-LS-MLE-PES`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}