re = /(ZB[\w\-]*)/
str = 'ZP-S,ZB-MA-S,ZB,ZB-MA-M,ZB-MA-B,ZP,PY,ZB-ME-S,ZB-ME-M,PY,ZB-ME-B,PY-S,PY-M,PY-B,ZP-B,ZB-MA-S-LS-MLE-PES'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end