package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)-.{5}`)
var str = `weave-net-kxpxc
weave-net-jjkki
weave-net-asdkk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}