import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "I?(V|X)?I{0,3}";
final String string = "IX. století\n"
+ "Matematika pro VII. třídu\n"
+ "Star Trek III\n"
+ "Karel IV.\n"
+ "papež Benedict V.\n"
+ "Bělá je X. část statutárního města Děčín.\n"
+ "III. patro\n"
+ "II. stupeň povodňové aktivity\n"
+ "Konstantin XI. Dragases";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}