# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"I?(V|X)?I{0,3}"
test_str = ("IX. století\n"
"Matematika pro VII. třídu\n"
"Star Trek III\n"
"Karel IV.\n"
"papež Benedict V.\n"
"Bělá je X. část statutárního města Děčín.\n"
"III. patro\n"
"II. stupeň povodňové aktivity\n"
"Konstantin XI. Dragases")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.