const regex = /(^\d{2})(\d{7}$|\d{9}$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\d{2})(\\d{7}$|\\d{9}$)', '')
const str = `12345678901`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}