$re = '/(^\d{2})(\d{7}$|\d{9}$)/';
$str = '12345678901';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);