$re = '/[A-D][0-9:\$\.\+\-\/]+[A-D]/m';
$str = 'A123456A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);