package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\[\[.*?]]|\*{3,}.*?\*+|\*+.*?\*{3,})(*SKIP)(*F)|\*\*(.+?)\*\*`)
var str = `[[**string**]]
**string**
[[**string**]]]
[[***string**]]
**test***
***test****`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}