re = /(?:\[\[.*?]]|\*{3,}.*?\*+|\*+.*?\*{3,})(*SKIP)(*F)|\*\*(.+?)\*\*/m
str = '[[**string**]]
**string**
[[**string**]]]
[[***string**]]
**test***
***test****'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end