using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-?(0|[1-9]\d*)?(\.\d+)?(e-?(0|[0-9]\d*))?|0x[0-9a-f]+)$";
string input = @"132.2343e8";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}