const regex = /^(-?(0|[1-9]\d*)?(\.\d+)?(e-?(0|[0-9]\d*))?|0x[0-9a-f]+)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-?(0|[1-9]\\d*)?(\\.\\d+)?(e-?(0|[0-9]\\d*))?|0x[0-9a-f]+)$', 'i')
const str = `132.2343e8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}