$re = '/@(\s+)?.+k\s+[[](\s+)?.+(\s)?[\][msg:\s"].+"[\]]/';
$str = '@
block [
user
][msg:"you messag"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);