re = /@(\s+)?.+k\s+[[](\s+)?.+(\s)?[\][msg:\s"].+"[\]]/
str = '@
block [
user
][msg:"you messag"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end