re = /(?:https:\/\/www\.expressandstar\.com\/[^\/]+\/local-hubs\/([^\/]+)\/|https:\/\/www\.expressandstar\.com\/[^\/]+\/([^\/]+)\/)/
str = 'https://www.expressandstar.com/news/local-hubs/wolverhampton/2023/06/21/prayer-event-set-to-bring-thousands-of-people-to-city-park/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end