import Foundation
let pattern = #"(?:https:\/\/www\.expressandstar\.com\/[^\/]+\/local-hubs\/([^\/]+)\/|https:\/\/www\.expressandstar\.com\/[^\/]+\/([^\/]+)\/)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://www.expressandstar.com/news/local-hubs/wolverhampton/2023/06/21/prayer-event-set-to-bring-thousands-of-people-to-city-park/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}