const regex = /(?<!version":")(\d+\.\d+\.\d+\.\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!version":")(\\d+\\.\\d+\\.\\d+\\.\\d+)', 'gm')
const str = `2018-09-15 15:59:41,311 INFO [Timer-0]-dashboard.PSDashboard: getProcessSummary --> processing output line
[32mOk: {"status":200,"name":"xya.com","version":"1.1.2.371","cis":"online","tagline":""}[0m
2018-09-15 15:59:40,106 INFO [Timer-0]-util.SSHUtil: Connecting to host [10.60.9.59] using provided credentials.
2018-09-15 15:59:40,209 INFO [Timer-0]-util.SSHUtil: Connected to host [10.60.9.29] using provided credentials.
2018-09-15 15:59:40,209 INFO [Timer-0]-util.SSHUtil: Connected to host 10.60.9.34 using provided credentials.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}