using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"id=""selectNOIOrg_do_frm_organization{([^{}\n]+)}""";
string input = @"<input type=""radio"" name=""frm.organization"" id=""selectNOIOrg_do_frm_organization{C5DF28FD-26EF-90DA-1214-BD72E0214F17}"" value=""{C5DF28FD-26EF-90DA-1214-BD72E0214F17}"" title=""College of St. Jude"" ext-ns-multiple=""frmorganization"">
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}