// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)id="selectNOIOrg_do_frm_organization{([^{}\n]+)}""#).unwrap();
let string = "<input type=\"radio\" name=\"frm.organization\" id=\"selectNOIOrg_do_frm_organization{C5DF28FD-26EF-90DA-1214-BD72E0214F17}\" value=\"{C5DF28FD-26EF-90DA-1214-BD72E0214F17}\" title=\"College of St. Jude\" ext-ns-multiple=\"frmorganization\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}