package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)[考进](.*)了(.*)`)
var str = `张华考上了北京大学
李萍进了中等技术学校
韩梅梅进了百货公司`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}