// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)[考进](.*)了(.*)").unwrap();
let string = "张华考上了北京大学
李萍进了中等技术学校
韩梅梅进了百货公司";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}